Modding > Spelunky 2 > Black Market Trainer


Practise robbing the black market. Offers a variety of items to start with and displays your shopkeeper aggro number.
By:
Jools
Downloads:
123
Mod Type:
Script
Install Code:
black-market-trainer
Added:
10 months, 1 week ago
Last Update:
8 months, 4 weeks ago
Average Rating:
No Ratings

Details


Lets you practise robbing the Black Market.
When starting a new run you will automatically end up at the top of the Black Market.

Starting money, bombs and ropes can be customised.
Supported backwear: Jetpack, Cape, Hoverpack, Telepack and Powerpack.
Supported held items: Shotgun, Freeze Ray, Machete, Teleporter, Metal Shield, Crossbow, Boomerang, Mattock, Camera, Webgun, Hou Yi Bow
Supported powerups: Climbing Gloves, Bomb Paste and Pitcher's Mitt

Instant Restart spawns you at the top of the Black Market, with the selected items and powerups from the mod settings.

Downloads


Latest Download
Downloads Name Uploaded
83 main.lua 8 months, 4 weeks ago
Past Downloads (1)
Downloads Name Uploaded
40 main.lua 10 months, 1 week ago

Preview Images


Comments (3)


Please log in to leave a comment.

5 months, 2 weeks ago

@desertblu3 Try updating to the latest Modlunky 2 and be sure to use Playlunky Version "nightly" (you can select it in Modlunky 2).

5 months, 2 weeks ago

Hey @desertblu3 looks like you're missing a global somehow, are you installing the mod through Modlunky 2? I just tried and it worked.
If that doesn't work, you can open the main.lua file in a text editor and replace "PRESENCE_FLAG.BLACK_MARKET" with "2". Let me know if that works!

6 months ago

Hello,
I Keep getting:
Playlunky :: Lua Error:
Mod: fyi.black-market-trainer
..."]:118: attempt to index a nil value (global 'PRESENCE_FLAG')
stack traceback:
..."]:117> in function <[string "meta.name = "Black Market Trainer"

It's the only mod I have installed. Anyone have any thoughts?